开发环境搭建——Node及Npm安装教程(Ubuntu篇)

2018/10/2 下午3:31:43 XXM

1.Node js 安装

sudo apt-get install nodejs

安装完成后 使用 node -v 查看版本

2.Npm 安装

sudo apt install npm

安装完成后 使用npm -v 查看版本

如果安装npm中出现以下错误

下列软件包有未满足的依赖关系:
 npm : 依赖: node-gyp (>= 0.10.9) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

我们采取最直接方式

打开 https://nodejs.org/en/download/

选择Linux 系统 (x64)位版本下载

2018-10-02 16-08-33屏幕截图.png

然后解压到 /opt目录下

创建软连接

sudo ln -s /opt/node-v10.8.0-linux-x64/bin/npm /usr/local/bin/npm

npm -v 查看版本

2018-10-02 16-14-36屏幕截图.png

日记本

如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!

赞赏支持
被以下专题收入,发现更多相似内容